Информатика, вопрос задал Аноним , 2 года назад

Написать программу в паскаль, суть следующая:
Пользователь вводит 10 целых чисел.. Полученная программа должна вывести на экран сумму только четных чисел. Пожалуйста помогите 100 баллов!!!!!

Ответы на вопрос

Ответил nastikots
1

Ответ:

program Chernovik;

var a,i,s: integer;

begin

s:=0;

for i:=1 to 10 do

begin

write(i:2,' число: ');

readln(a);

if a mod 2 = 0 then s:=s+a

end;

write('Сумма чётных чисел: ',s)

end.

Объяснение:

Используем цикл с параметром (переменная i)

Вводим число (переменная a)

Если число чётное, то увеличиваем сумму (переменная s) на него

Выводим сумму

Новые вопросы