написать программу в паскаль(с помощью множественного выбора), которая получает день и номер месяца и определяет дату следующего дня
Ответы на вопрос
Ответил ZaharovVasya
0
Var n,m:interer;
Begin
write('Введите день') ; Readln(d);
write('Введите месяц'); Readln(m);
if (m = 2) and (d=28) then writeln('День - 1',' Месяц - 3'); if (m=1) or (m=3) or (m=5) or (m=7) or (m=8) or (m=10) or (m=12) then if (d>1) and (d<31) then begin d:=d+1; writeln('День -',d,'Месяц- ',m); end else if d=31 then begin m:=m+1; wrteln('День - 1','Месяц- ',m); end; if (m=2) or (m=4) or (m=6) or (m=9) or (m=11) they if d<30 then begin d:=d+1; writeln('День -',d,'Месяц- ',m); end else d=30 then begin m:=m+1; wrteln('День - 1','Месяц- ',m); end;
readln;
end.
НЕДОРАБОТАНА
Begin
write('Введите день') ; Readln(d);
write('Введите месяц'); Readln(m);
if (m = 2) and (d=28) then writeln('День - 1',' Месяц - 3'); if (m=1) or (m=3) or (m=5) or (m=7) or (m=8) or (m=10) or (m=12) then if (d>1) and (d<31) then begin d:=d+1; writeln('День -',d,'Месяц- ',m); end else if d=31 then begin m:=m+1; wrteln('День - 1','Месяц- ',m); end; if (m=2) or (m=4) or (m=6) or (m=9) or (m=11) they if d<30 then begin d:=d+1; writeln('День -',d,'Месяц- ',m); end else d=30 then begin m:=m+1; wrteln('День - 1','Месяц- ',m); end;
readln;
end.
НЕДОРАБОТАНА
Ответил ZaharovVasya
0
там с декабрем исправь, а то времени нету
Новые вопросы
Химия,
2 года назад
География,
2 года назад
Математика,
10 лет назад
Химия,
10 лет назад
Литература,
10 лет назад
Биология,
10 лет назад