Написать программу (в паскаль) по закупке товаров в магазине на определённую сумму денег, не превышающую заданное количество денег.
ВХОДНЫЕ ДАННЫЕ: С клавиатуры вводится сумма, на которую предполагается произвести покупки. Затем вводятся цена и количество товара №1, товара №2 и т.д. до тех пор пока не будет исчерпана сумма денег.
Ответы на вопрос
Ответил M0ndt4R
0
uses crt;
var s:integer;
b,y,a:real;
begin
write('Введите сумму денег, на которую собираетесь произвести покупки: ');
read(a);
while a>0 do begin
s:=s+1;
write('Товар №',s,': ');
read(b);
write('Введите количество: ');
read(y);
a:=a-(b*y);
end;
end.
var s:integer;
b,y,a:real;
begin
write('Введите сумму денег, на которую собираетесь произвести покупки: ');
read(a);
while a>0 do begin
s:=s+1;
write('Товар №',s,': ');
read(b);
write('Введите количество: ');
read(y);
a:=a-(b*y);
end;
end.
Ответил ad1997ya
0
uses crt;
var
sum,x,itog: real;
i,y: integer;
begin
i:=1;
itog:=0;
write ('Start summa: ');
readln (sum);
while (itog<sum) do
begin
write ('¹',i,': ');
i:=i+1;
readln (x);
write ('Kol-vo: ');
readln (y);
itog:=itog+y*x;
end;
if (itog>sum) then
writeln ('Itog: ',itog-y*x)
else
writeln ('Itog: ',itog);
end.
var
sum,x,itog: real;
i,y: integer;
begin
i:=1;
itog:=0;
write ('Start summa: ');
readln (sum);
while (itog<sum) do
begin
write ('¹',i,': ');
i:=i+1;
readln (x);
write ('Kol-vo: ');
readln (y);
itog:=itog+y*x;
end;
if (itog>sum) then
writeln ('Itog: ',itog-y*x)
else
writeln ('Itog: ',itog);
end.
Ответил ad1997ya
0
исправил, чтобы не превышало начальную сумму.
Ответил M0ndt4R
0
у меня меньше программа
Ответил ad1997ya
0
я рад
Новые вопросы