Написать программу в Pascal по 2 способам repeat и while.Сделать блок-схему
Приложения:

Ответы на вопрос
Ответил JolanTrue
0
На TP7
var
x,i:integer;
s:real;
begin
write('vvedite x: ');
readln(x);
i:=1;
repeat
i:=i+1;
s:=s+i*cos(i*x);
until i=15;
writeln('s=',s);
end.
var
x,i:integer;
s:real;
begin
write('vvedite x: ');
readln(x);
i:=1;
while i<16 do
begin
i:=i+1;
s:=s+i*cos(i*x);
end;
writeln('s=',s);
end.
Имейте в виду, что алгоритмы построены по коду автоматически, и препод это сразу увидит.
var
x,i:integer;
s:real;
begin
write('vvedite x: ');
readln(x);
i:=1;
repeat
i:=i+1;
s:=s+i*cos(i*x);
until i=15;
writeln('s=',s);
end.
var
x,i:integer;
s:real;
begin
write('vvedite x: ');
readln(x);
i:=1;
while i<16 do
begin
i:=i+1;
s:=s+i*cos(i*x);
end;
writeln('s=',s);
end.
Имейте в виду, что алгоритмы построены по коду автоматически, и препод это сразу увидит.
Приложения:

Новые вопросы
Русский язык,
2 года назад
Українська мова,
2 года назад
Информатика,
8 лет назад
Математика,
8 лет назад
Алгебра,
9 лет назад
Химия,
9 лет назад