Написать программу в Pascal по 2 способам for и while.
Задание:Вывести на экран числа оканчивающаяся на 3 в промежутке от n до 150
Ответы на вопрос
Ответил asoiiu
0
while:
var
n: integer;
begin
write('Введите начало диапазона (n): ');
readln(n);
while n < 150 do
begin
if n mod 10 = 3
then write(n, ' ');
n := n + 1; end;
end.
for:
var
n, i: integer;
begin
write('Введите начало диапазона (n): ');
readln(n);
for i := n to 150 do
if n mod 10 = 3
then write(i, ' ');
end.
var
n: integer;
begin
write('Введите начало диапазона (n): ');
readln(n);
while n < 150 do
begin
if n mod 10 = 3
then write(n, ' ');
n := n + 1; end;
end.
for:
var
n, i: integer;
begin
write('Введите начало диапазона (n): ');
readln(n);
for i := n to 150 do
if n mod 10 = 3
then write(i, ' ');
end.
Приложения:

Ответил oxid2005
0
Блок-схему можете приложить пожалуйста
Новые вопросы