Информатика, вопрос задал ShutovaMaria , 10 лет назад

Написать программу в Pascal.
Даны два угла треугольника (в градусах). Определить, существует ли такой треугольник. Если да, то будет ли он прямоугольным.

Ответы на вопрос

Ответил Aillianna
0
var
    a, b: integer;

begin
    readln(a, b);
    if a + b >= 180 then
        writeln('Такой треугольник не может существовать')
    else if (a = 90) or (b = 90) or (a + b = 90) then
        writeln('Это прямоугольный треугольник')
    else
        writeln('Это треугольник')
end.
Новые вопросы