Информатика, вопрос задал artym24 , 8 лет назад

Написать программу в Pascal

Даны число A>0, числа x1,x2....
Необходимо вводить числа x1,x2.... , пока сумма модулей введенных чисел будет меньше A. Определить число введенных чисел.

P.S В поисковике искал, нашел 2 какие-то странные программы, они мне не подходят

Ответы на вопрос

Ответил DonPedro80
0
var
  a,x,k,s:integer;
begin
  Write('a=');
  Readln(a);
  k:=0;
  s:=0;
  while s<a do
  begin
    Read(x);
    s:=s+abs(x);
    Inc(k)
  end;
  Writeln('Введено чисел ',k)
end.
Ответил artym24
0
"пока сумма модулей введенных чисел будет меньше A", а твоя программа считает вроде как равное числу А, или я неправильно понимаю задачу?
Ответил DonPedro80
0
Нет, Вы неправильно понимаете код программы. while s
Ответил DonPedro80
0
while s
Ответил DonPedro80
0
Странно. Не могу набрать знак меньше
Ответил DonPedro80
0
while s меньше а do - это "пока сумма модулей меньше а выполняем..."
Новые вопросы