Информатика, вопрос задал m0nster99 , 8 лет назад

Написать программу в Pascal.
Дана матрица, нужно вычислить среднее значение чисел в каждом столбце матрицы

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1633 от 10.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (m,n):=ReadInteger2('Количество строк и столбцов в матрице:');
  Writeln('*** Исходная матрица ***');
  var a:=MatrRandom(m,n,-99,99);
  a.Println(4); Writeln(4*n*'-');
  Writeln('Средние значения по столбцам');
  a.Cols.Select(col->col.Average).Println
end.

Пример
Количество строк и столбцов в матрице: 6 7
*** Исходная матрица ***
 -70  66 -81  -2  42  22  -7
 -42   4 -27  32   6 -38 -81
 -22 -60 -65 -26 -87   2 -49
 -59 -48  -5 -11  38 -27  98
 -94 -47  86 -11 -13 -92 -43
 -92  89 -58  37  20 -14 -45
----------------------------
Средние значения по столбцам
-63.1666666666667 0.666666666666667 -25 3.16666666666667 1 -24.5 -21.1666666666667
Новые вопросы