Написать программу в Pascal
числа a,b и c вводятся с клавиатуры.найти max(a,a+b)+max(a,b+c)/1+max(a+b*c,1,5)
Аноним:
Какая версия Паскаля?
Ответы на вопрос
Ответил Аноним
2
Уверен, что формула в условии написана неверно, но уж как написано...
var
a,b,c:real;
begin
Write('Введите a,b,c: '); Read(a,b,c);
Writeln('Результат: ',max(a,a+b)+max(a,b+c)/1+max(max(a+b*c,1),5))
end.
Тестовое решение:
Введите a,b,c: -3 5.5 4
Результат: 31
А вот так, на мой взгляд, должно быть:
var
a,b,c:real;
begin
Write('Введите a,b,c: '); Read(a,b,c);
Writeln('Результат: ',(max(a,a+b)+max(a,b+c))/(1+max(a+b*c,1.5)))
end.
Тестовое решение:
Введите a,b,c: -3 5.5 4
Результат: 0.6
var
a,b,c:real;
begin
Write('Введите a,b,c: '); Read(a,b,c);
Writeln('Результат: ',max(a,a+b)+max(a,b+c)/1+max(max(a+b*c,1),5))
end.
Тестовое решение:
Введите a,b,c: -3 5.5 4
Результат: 31
А вот так, на мой взгляд, должно быть:
var
a,b,c:real;
begin
Write('Введите a,b,c: '); Read(a,b,c);
Writeln('Результат: ',(max(a,a+b)+max(a,b+c))/(1+max(a+b*c,1.5)))
end.
Тестовое решение:
Введите a,b,c: -3 5.5 4
Результат: 0.6
Ответил uropb123
1
function max (var first,second:real): real;
begin
if first > second then max:=first else max:= second;
end;
var a,b,c,y : real;
begin
writeln('Ведите a,b,c через пробел и нажмите Enter: ');
read(a,b,c);
y:= max(a,a+b)+max(a,b+c)/1+max(a+b*c,1.5);
writeln('Ответ: ',y);
end.
begin
if first > second then max:=first else max:= second;
end;
var a,b,c,y : real;
begin
writeln('Ведите a,b,c через пробел и нажмите Enter: ');
read(a,b,c);
y:= max(a,a+b)+max(a,b+c)/1+max(a+b*c,1.5);
writeln('Ответ: ',y);
end.
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Русский язык,
2 года назад
География,
2 года назад
Математика,
7 лет назад
Математика,
7 лет назад