Написать программу в Pascal:
1)
Компьютер спрашивает: "Что сегодня нужно всем?" и если получает ответ ЭВМ, то пишет "Ну, конечно ЭВМ!", иначе "Это тоже нужно всем, но нужнее ЭВМ!"
2)
Написать программу, по которой компьютер приветствовал бы только своего хозяина, а при попытке ввести какое-либо другое имя спрашивал бы: "А где (например) Вася?"
Нужно использовать операторы ветвления.
Ответы на вопрос
Ответил Puz1koO
0
1)
var
s:string;
begin
writeln('Что сегодня нужно всем?');
readln(s);
if s = 'ЭВМ' then
writeln('Ну, конечно ЭВМ!')
else writeln('Это тоже нужно всем, но нужнее ЭВМ!');
end.
2)
const
n='Григорий';
var
s:string[15];
begin
writeln('*Хозяин компьютера: Григорий*');
write('Введите ваше имя: '); readln (s);
if s = n then writeln('Приветствую вас!')
else writeln('А где ',n,'?');
end.
Если моё решение помогло вам, пометьте его лучшим. Спасибо!
Новые вопросы
Русский язык,
2 года назад
Химия,
2 года назад
История,
7 лет назад
Физика,
7 лет назад
Биология,
8 лет назад
Математика,
8 лет назад