Информатика, вопрос задал nuta25129 , 7 лет назад

написать программу, в который пользователь вводит число и показатель степени,в которую возвести число , используя цикл с постусловием

Ответы на вопрос

Ответил alia1688
0

Циклом долго.  

Эта проблема уже давно решена. вот готовая отлаженная функция:  

Function Pow(A,B:Real):Real;  

{ Функция возведения в степень (A^B) }  

Var T:Real;  

Begin  

T := Abs(A);  

If A < 0 Then Pow := (-1)*Exp(B*Ln(T))  

Else Pow := Exp(B*Ln(T));  

End;

Ответил nuta25129
0
спасибо конечно,но мне именно с циклов надо,задали дз
Ответил nuta25129
0
можешь помочь?
Ответил alia1688
0
Program stp;Uses Crt;
Var C,A,N,s:Integer;
Begin;CLRSCR;
Write('Vvedite chislo: ');Readln(A);
Write('VVedite stepen: ');Readln(N);
c:=1;s:=n;

While N<>0 Do
Begin
C:=C*A;
N:=N-1;
End;
Writeln('chislo ',A,' v stepeni ',s,' ravno ',C);Readln;
End. Вроде так...
Ответил nuta25129
0
спасибо большое
Новые вопросы