написать программу в которой пользователю предоставлено 3 товара, указана стоимость и количество. В случае если пользователь ввел колличество товара и нажал кнопку купить, то колличество товара уменьшается, в случае нуля выдаёт окно о отсуствии товара с# Срочно надо!
Ответы на вопрос
using System;
using System.Collections.Generic;
public class Program
{
public static void Main()
{
Dictionary<string, int> товары = new Dictionary<string, int>()
{
{ "Товар 1", 10 },
{ "Товар 2", 5 },
{ "Товар 3", 20 },
};
while(true)
{
Console.WriteLine("Доступные товары:");
foreach (var товар in товары)
{
Console.WriteLine($"Название: {товар.Key}, количество: {товар.Value}");
}
Console.Write("Введите название товара, который хотите купить: ");
string выбранныйТовар = Console.ReadLine();
if (товары.ContainsKey(выбранныйТовар))
{
if (товары[выбранныйТовар] > 0)
{
товары[выбранныйТовар]--;
Console.WriteLine($"Вы купили {выбранныйТовар}. Осталось {товары[выбранныйТовар]} штук.");
}
else
{
Console.WriteLine("Извините, этого товара нет в наличии.");
}
}
else
{
Console.WriteLine("Извините, вы ввели неправильное название товара.");
}
}
}
}