Информатика, вопрос задал kupfunny , 2 года назад

Написать программу в которой определяется сумма s всех целых чисел в интервале, заданном переменными n и m, а так же сумма sa четных и sb нечетных чисел в том же интервале, на языке pascal

Ответы на вопрос

Ответил gfhjkmgfhjkm20
1

Ответ:

var i,n,m,s,sa,sb: integer;

begin

write('n = ');

readln (n);

write('m = ');

readln (m);

for i:=n to m do

begin

s:=s+i;

if i mod 2 = 0 then sa:=sa+i else sb:=sb+i

end;

write('s = ',s,' sa = ',sa,' sb = ',sb)

end.

Объяснение:

Если интервал [n,m]


Аноним: помоги если нетрудно
Аноним: https://znanija.com/task/33641719
Аноним: помоги пж
Аноним: https://znanija.com/task/33642313
Новые вопросы