Информатика, вопрос задал Tимуджин , 8 лет назад

Написать программу в которой. Даны 3 положительных числа и определить можно ли построить треугольник со сторонами , длинны которых равны этим числам и является ли этот треугольник прямоугольным

Ответы на вопрос

Ответил всеволод30
0
#include<iostream>
using namespace std;
int main() {
int a,b,c;
cin >> a >> b >> c;
if ((a+b>c)&(a+c>b)&(c+b>a)) {
if (a*a+b*b=c*c)||(b*b+c*c=a*a)||(c*c+a*a=b*b)
cout << "треугольник прямоугольный";
else cout << "треугольник не прямоугольный";
}
else cout << "их данных сторон невозможно сделать треугольник";
return 0;
}
Новые вопросы