Написать программу в Delphi 7, содержащую цикл для вычисления функции
если n=10, A0=0.75, A1=1.6, A2=A3=...=A10=2.0; X изменяется с шагом h=0.2 от X1=0 дo X2=2.0.
Ответы на вопрос
Ответил archery
0
const
a: array[1..11] of real = (0.75, 1.6, 2, 2, 2, 2, 2, 2, 2, 2, 2);
var
x, h, x1, x2: real;
function F(x: real): real;
var
i: integer;
x_n, res : real;
begin
res := a[1];
x_n := 1;
for i := 1 to 10 do
begin
x_n := x_n * x;
res := res + a[i + 1] * x_n;
end;
F := res;
end;
begin
x1 := 0; x2 := 2;
h := 0.2;
x := x1;
repeat
writeln('x = ', x:3:1, ' y = ', F(x):9:3);
x := x + h;
until x > x2;
end.
a: array[1..11] of real = (0.75, 1.6, 2, 2, 2, 2, 2, 2, 2, 2, 2);
var
x, h, x1, x2: real;
function F(x: real): real;
var
i: integer;
x_n, res : real;
begin
res := a[1];
x_n := 1;
for i := 1 to 10 do
begin
x_n := x_n * x;
res := res + a[i + 1] * x_n;
end;
F := res;
end;
begin
x1 := 0; x2 := 2;
h := 0.2;
x := x1;
repeat
writeln('x = ', x:3:1, ' y = ', F(x):9:3);
x := x + h;
until x > x2;
end.
Ответил archery
0
какя именно строчка и каккая именно ошибка? кстати какая версия паскаля?
Ответил archery
0
убери форматирование наверно
Новые вопросы