Информатика, вопрос задал halilovashahla , 9 лет назад

Написать программу, суммирующую положительные элементы массива, полученную сумму возвести в квадрат (сделать через Pascal)(пожалуйста срочно надо ни то 2 поставят)

Ответы на вопрос

Ответил ZaharovVasya
0
Const N = 10;
Var i,S:integer; m:array [1..N] of integer;
Begin       
Writeln('Введите массив');       
for i:=1 to 10 do begin       
readln(m[i]);       
if m[i]>0 then S:=S+m[i]; end;       
S:=sqr(S);       
writeln('Сумма^2 равна ',S);       
readln;       
end.
Новые вопросы