Информатика, вопрос задал nurakyku , 2 года назад

Написать программу создающую массив из N целых элементов со случайными значениями в диапазоне [-50; 50]. Подсчитать среднее арифметическое элементов массива, кратных трем.

Ответы на вопрос

Ответил karina10Nebo
0

Ответ:

const n=20;

var a:array[1..n] of integer;

i,b,c:integer; k:real;

Begin

for i:=1 to n do read(a[i]);

b:=0;

c:=0;

for i:=1 to n do begin

if (a[i] mod 3 = 0) then begin

b:=b+a[i];

c:=c+1;

end;

end;

 

k:=b/c;

writeln(k);

end.

Новые вопросы