Написать программу,составить алгоритм вычисления среднего арифметического значения массива из 15 целых чисел. Числа вводить с использованием генератора случайных чисел. Помогите пожалуйста итоговая оценка решается...
Ответы на вопрос
Ответил Аноним
0
var
i,n:integer;
s:real;
begin
Randomize;
writeln('Исходные числа');
s:=0;
for i:=1 to 15 do begin
n:=random(100)-50;
write(n:4);
s:=s+n
end;
s:=s/15;
writeln;
writeln('Среднее арифметическое равно ',s)
end.
Тестовое решение:
Исходные числа
-5 -41 -36 44 -2 8 -24 10 0 20 -8 15 14 35 44
Среднее арифметическое равно 4.93333333333333
i,n:integer;
s:real;
begin
Randomize;
writeln('Исходные числа');
s:=0;
for i:=1 to 15 do begin
n:=random(100)-50;
write(n:4);
s:=s+n
end;
s:=s/15;
writeln;
writeln('Среднее арифметическое равно ',s)
end.
Тестовое решение:
Исходные числа
-5 -41 -36 44 -2 8 -24 10 0 20 -8 15 14 35 44
Среднее арифметическое равно 4.93333333333333
Новые вопросы
Математика,
2 года назад
История,
2 года назад
Математика,
9 лет назад
Математика,
9 лет назад
Литература,
10 лет назад
Физика,
10 лет назад