Написать программу, сокращающую обыкновенные дроби. Числитель и знаменатель вводятся с клавиатуры. В программе использовать цикл с постусловием. Пример. вводятся числа: 10 15 результат: 2 / 3
Ответы на вопрос
Ответил Kitsu
0
var i,x,y:integer;
b:boolean;
begin
readln(x,y);
for i:=2 to x do
if (x div i=x/i) and (y div i=y/i) then begin
x:=x div i;
y:=y div i;
end;
writeln(x,' ',y);
end.
Новые вопросы
Физика,
6 лет назад
Русский язык,
6 лет назад
Физика,
10 лет назад
Геометрия,
10 лет назад
Алгебра,
10 лет назад