Информатика, вопрос задал Дирик666 , 8 лет назад

Написать программу случайным образом формирующую числовой массив в диапазоне [-10,10]

Приложения:

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  var a:=ArrRandom(n,-10,10);
  for var i:=0 to n-2 do Write('A[',i+1,']=',a[i],', ');
  Writeln('A[',n,']=',a[n-1]);
  Writeln('Четных элементов- ',a.Where(t->t.IsEven).Count);
  a.Transform(t->t<0?1:0); a.Println;
end.

Пример
n= 13
A[1]=-10, A[2]=-2, A[3]=-8, A[4]=6, A[5]=-1, A[6]=3, A[7]=-10, A[8]=-3, A[9]=-6, A[10]=5, A[11]=7, A[12]=-3, A[13]=5
Четных элементов- 6
1 1 1 0 1 0 1 1 1 0 0 1 0
Новые вопросы