Написать программу считающие нечетные элементы и выводит среднеарифметическое четных. помогите, пожалуйста )))))
Ответы на вопрос
Ответил Fastlike
0
Program chet_nechet;
const n=20;
type mas=array[1..n] of integer;
var i,k,sum,sum2,sr:integer; a:mas;
begin
sum:=0;
sum2:=0;
k:=0;
write('Массив: ');
for i:=1 to n do
begin
a[i]:=random(100);
write(a[i],' ');
if a[i] mod 2=0 then begin k:=k+1; sum2:=sum2+a[i]; end
else sum:=sum+a[i];
end;
writeln();
writeln('Сумма нечётных чисел=',sum);
write('Среднее арифметическое четных чисел=',sum2/k:0:2);
end.
Если нужно что-то объяснить, то пишите...
const n=20;
type mas=array[1..n] of integer;
var i,k,sum,sum2,sr:integer; a:mas;
begin
sum:=0;
sum2:=0;
k:=0;
write('Массив: ');
for i:=1 to n do
begin
a[i]:=random(100);
write(a[i],' ');
if a[i] mod 2=0 then begin k:=k+1; sum2:=sum2+a[i]; end
else sum:=sum+a[i];
end;
writeln();
writeln('Сумма нечётных чисел=',sum);
write('Среднее арифметическое четных чисел=',sum2/k:0:2);
end.
Если нужно что-то объяснить, то пишите...
Ответил koshmary
0
Спасибо большое!!!:)
Новые вопросы
Математика,
2 года назад
Биология,
9 лет назад