Информатика, вопрос задал UAGamesTactics , 8 лет назад

Написать программу С++ Заполнить массив двадцатью первыми натуральными числами,делящимися нацело на 13 или на 17 и находящимися в интервале,левая граница которого равна 300

Ответы на вопрос

Ответил MaxLevs
0
c++14

#include <iostream>
#define k 20
using namespace std;
int main() {
int arr[k];
bool flag = false;
for(int i = 0, l = 1; i < k; ++i){
arr[i] = l*((!flag)?13:17);
if(flag) l++;
flag = !flag;
if(arr[i] >= 300)
cout << arr[i] << " ";
else
--i;
}
return 0;
}
Приложения:
Ответил MaxLevs
0
ах, 300...
Ответил MaxLevs
0
сейчас поправлю
Ответил MaxLevs
0
как менять картинки через мобильное приложение, я не знаю, но суть должна быть ясна
Ответил UAGamesTactics
0
Нужно через массивы сделать
Ответил MaxLevs
0
Что значит "через массивы"? В коде и так есть массив "arr". Элемент хоть и выводится на той же итерации цикла, делается это именно из массива
Новые вопросы