Написать программу с помощью цикла while которая производит суммирование любых десяти чисел. Буду очень благодарен!
Ответы на вопрос
Ответил m0nclous
0
Var i:integer; n,sum:real;
Begin
Write('Введите 10чисел: ');
while (i<>10) do begin
readln(n);
sum:=sum+n;
i:=i+1;
end;
writeln('Сумма этих чисел - ',sum);
end.
Begin
Write('Введите 10чисел: ');
while (i<>10) do begin
readln(n);
sum:=sum+n;
i:=i+1;
end;
writeln('Сумма этих чисел - ',sum);
end.
Ответил m0nclous
0
Да что тут путаться?) While () это пока выполняется то условие которое в скобках, если оно не выполняется то цикл завершается
for i:=1 to 10 do ... это цикл со счётчиком, то есть в данном случае цикл выполнится 10раз, а если быть точнее то до момента как i станет равна 10, каждый раз i увеличивается на 1, но ты так же можешь i уменьшать или увеличивать в самом цикле, например for i:=2 to 10 do i:=i-1; этот цикл будет бесконечным т.к. i никогда не станет 10 потому-что каждый раз как i
for i:=1 to 10 do ... это цикл со счётчиком, то есть в данном случае цикл выполнится 10раз, а если быть точнее то до момента как i станет равна 10, каждый раз i увеличивается на 1, но ты так же можешь i уменьшать или увеличивать в самом цикле, например for i:=2 to 10 do i:=i-1; этот цикл будет бесконечным т.к. i никогда не станет 10 потому-что каждый раз как i
Ответил m0nclous
0
увеличит на 1, мы уменьшаем на 1.
Ответил m0nclous
0
repeat .... until(); тут мы словом repeat показываем начало кода который будет зациклен, а until() мы показываем где будет конец кода и в скобочках пишем условие, выполнив которое цикл закончится, например repeat i:=i+1; until(i=5);
в данном случае цикл проиграется 5раз, если учитывать что изначально i была равна 0
в данном случае цикл проиграется 5раз, если учитывать что изначально i была равна 0
Новые вопросы
Физика,
2 года назад
Математика,
2 года назад
Химия,
10 лет назад
Информатика,
10 лет назад
Математика,
10 лет назад