Информатика, вопрос задал zaikinaanastasya , 2 года назад

Написать программу с помощью цикла с постусловием (repeat). ПАСКАЛЬ
Вычислить сумму чисел в диапазоне от 19 до 51, если они делятся на 5.


антагонист: включительно?
zaikinaanastasya: да

Ответы на вопрос

Ответил GenusQ
1
// Pascal
  var sum : integer;
      i: integer;
begin
  sum := 0;
  i := 19;
  repeat
    if i mod 5 = 0 then
      sum := sum + i;
    i := i + 1;
  until (i > 51);
  writeln(sum);
end.

Ответил антагонист
0
var a,b,c:
integer;
begin
a:=19;
b:=0;
repeat
if (a mod 5 = 0) then
b:=a+b;
a:=a+1;
until (a>52);
writeln(b);
end.
Новые вопросы