написать программу с использованием цикла с постусловием рараметром и составит и блок схемы дано натуральное число определить количество его нечетеых делителей
Ответы на вопрос
Ответил mesteron98
0
program dividers;
var
c,i,n :Integer;
begin
readln(n);
repeat
if ( (n mod i) = 0 ) and ( (i mod 2) <> 0) then c:= c + 1;
if ( (n / i) mod 2) <> 0 then c:= c + 1;
i:= i + 1;
until i < (sqrt(n) + 1);
writeln(c);
end.
var
c,i,n :Integer;
begin
readln(n);
repeat
if ( (n mod i) = 0 ) and ( (i mod 2) <> 0) then c:= c + 1;
if ( (n / i) mod 2) <> 0 then c:= c + 1;
i:= i + 1;
until i < (sqrt(n) + 1);
writeln(c);
end.
Новые вопросы
ОБЖ,
2 года назад
География,
2 года назад
Математика,
9 лет назад
Алгебра,
9 лет назад
Математика,
9 лет назад