Информатика, вопрос задал zzzzzzzzzzzzzzzzm , 2 года назад

написать программу, результатом которой является число кратное 3. поиск осуществляем из массива в 20 чисел (числа от -20 до 20)
Pascal


nastikots: Любое число из массива кратное 3? Или все числа кратные 3 из массива?
zzzzzzzzzzzzzzzzm: любое

Ответы на вопрос

Ответил nastikots
2

Ответ:

program z1;

var a: array [1..20] of integer;

i,k,ch: integer;

begin

randomize;

k:=0;

ch:=0;

write('Массив: ');

for i := 1 to 20 do

begin

a[i] := random(41) - 20;

write(a[i],' ');

if a[i] mod 3 = 0 then

begin

k:=1;

ch:=a[i]

end

end;

writeln;

if k=0 then write('В массиве нет чисел, кратных 3')

else write('Число кратное 3: ',ch)

end.

Объяснение:

Число 0 кратно любому натуральному числу


ANIMEROCK: круто
Новые вопросы