Информатика, вопрос задал Dimka2264 , 7 лет назад

Написать программу решения задачи в Pascal ABC. Задача: Занятия в школе начинаются в 8:30. Урок длится 40 минут, перерывы между уроками – 15 минут. Ввести номер урока и вывести время его окончания. (при решении используйте div и mod).

Ответы на вопрос

Ответил farodis
0

var n,du,dp,tn,tk,h,m:integer;

begin

writeln(' ');

repeat

write('Введите номер урока от 1 до 6 n=');

readln(n);

until n in [1..6];

tn:=480+30; (*начало занятий*)

du:=45; (*длина урока*)

dp:=10; (*длина перерыва*)

if n=1 then tk:=tn+du (*первый урок*)

else tk:=tn+du+(n-1)*(du+dp);(*другие*)

h:=tk div 60;

m:=tk mod 60;

write(h,'-',m);

end.

Ответил Dimka2264
0
C делайте плизз через div и mod
Ответил farodis
0
внизу див и мод стоит
Ответил Dimka2264
0
нету вродь
Ответил Dimka2264
0
а всё спасибо большое
Ответил farodis
0
с конца 3 и 4 строчка
Новые вопросы