Информатика, вопрос задал olololo234 , 2 года назад

Написать программу решения задачи: С клавиатуры вводят 9 вещественных чисел. Занести в типизированный файл только отрицательные из введённых чисел. При форматирование файла учесть, что в файле данные должны быть записаны в строку.

Ответы на вопрос

Ответил Аноним
0
var
  i:integer;
  n:real;
  f:file of real;
begin
  Assign(f,'in.dat');
  Rewrite(f);
  Writeln('Введите 9 вещественных чисел');
  for i:=1 to 9 do begin Read(n); Write(f,n) end;
  Close(f)
end.

Пример ввода:
Введите 9 вещественных чисел
2 -5 1.45 -81.34 5.63e-10 0 -13.45e12 17.5353 -12e-3 1000


Новые вопросы