Информатика, вопрос задал fffomka49 , 1 год назад

Написать программу решения уравнения ах3 + Ьх = 0 для произвольных а, Ь.
C#

Ответы на вопрос

Ответил iknowthatyoufeelbro
0

using System;

using System.Collections.Generic;

public class Task

{

public static void Main()

{

 //Два вещественных числа на одной строке с любым числом пробелов

 Console.WriteLine("Введите коэффициенты a, b:");

 var s = Console.ReadLine().Split(' ', StringSplitOptions.RemoveEmptyEntries);

 double a = Convert.ToDouble(s[0]);

 double b = Convert.ToDouble(s[1]);

 Console.WriteLine("Решения уравнения ({0})*x^3+({1})*x=0:", a, b);

 //a*x^3+bx=0

 //x(a*x^2+b)=0

 //x = 0 или x = +-sqrt(-b/a)

 

 List<double> roots = new List<double>();

 roots.Add(0);

 const double eps = 1e-7; //точность для сравнения с нулем вещественных чисел

 if (Math.Abs(a) < eps)

 {

  if (Math.Abs(b) < eps)

  {

   Console.WriteLine("Бесконечное количество решений");

   return;

  }

 }

 else

 {

  double c = -b/a;

  if (c > eps)

  {

   c = Math.Sqrt(c);

   roots.Add(-c);

   roots.Add(c);

  }

 }

 foreach(var x in roots)

 {

  Console.Write("{0} ", x);

 }

 Console.WriteLine();

}

}


Studentic228: Здравствуйте, помогите с информатикой(программирование) пожалуйста: https://znanija.com/task/33465240
Новые вопросы