написать программу решения системы линейных уравнений с двумя неизвестными. паскаль
Ответы на вопрос
Program SYSTEM;
procedure Korni(a,b,c1,d,e,c2:real;var x,y:real);
begin
if abs(a*e-d*b)<=0.0001 then write('Система не определена!')
else
begin
{приведение матрицы к треугольному виду}
{обнуляем коэффициент при х1 во 2 уравнении}
e:=b+e*(-a/d); c2:=c1+c2*(-a/d);
{ищем корни, начиная с последнего}
y:=c2/e;
x:=(c1-b*y)/a;
end;
end;
var a,b,h,d,e,f,x,y:real;
begin
writeln('Введите коэффициенты первого уравнения:');
readln(a,b,h);
writeln('Введите коэффициенты второго уравнения:');
readln(d,e,f);
Korni(a,b,h,d,e,f,x,y);
writeln('Корни системы:');
write('x=',x:0:2,' y=',y:0:2);
readln;
end.
===== PascalABC.NET =====
begin
// a1 * x + b1 * y = c1
// a2 * x + b2 * y = c2
var (a1, b1, c1) :=
ReadReal3('Коэффициенты 1 уравнения:');
var (a2, b2, c2) :=
ReadReal3('Коэффициенты 2 уравнения:');
var d := a1 * b2 - a2 * b1;
if Abs(d) < 1e-14 then
Println('Система несовместна')
else
begin
var dx := c1 * b2 - c2 * b1;
var x := dx / d;
var dy := a1 * c2 - a2 * c1;
var y := dy / d;
Println(x, y)
end
end.