Написать программу решения линейного уравнения ax=b,a,b Вводим с клавиатуры
Язык - paskal
Ответы на вопрос
uses Crt;
var a, b, x : real;
BEGIN
ClrScr;
Write('Введите число a = ');
ReadLn(a);
Write('Введите число b = ');
ReadLn(b);
if ((a=0) and (b=0)) then
WriteLn('Уравнение имеет бесконечное множество решений: х*0 + 0 = 0.')
else if ((a=0) and (b<>0)) then
WriteLn('Уравнение не имеет решений.')
else if (a<>0) then
begin
x:= -(b/a);
WriteLn('x = ', x);
end
END.
var
a, b : real;
begin
writeln('ax=b');
write('введите a, b: ');
readln(a, b);
writeln(a, 'x=', b);
if (a = 0) and (b = 0) then writeln('x= бесконечное множество')
else if (a = 0) and (b <> 0) then writeln('уравнение не имеет решений')
else begin
writeln('x=', b, '/', a);
writeln('x=', b/a);
end;
end.