Информатика, вопрос задал dmitymerkovsky , 1 год назад

Написать программу, решающую задачу: Вася имеет Х рублей на карманные расходы. Сколько банок газировки он сможет купить, если газировка стоит Y рублей.

Ответы на вопрос

Ответил chatskyinc
0

Ответ:

var money, price, count: integer;

begin

 writeln('Введите количество денег и стоимость одной газировки');

 readln(money, price);

 count := 0;

 if(money >= price) then begin repeat

   money := money - price;

   inc(count, 1);

 until money < price;  

 writeln('Петя может купить ', count, ' банок газировки');

 end else writeln('Вася не может купить газировку.');

end.

Объяснение:

1) Создаём переменные

money - количество денег у Васи.

price - цена одной газировки.

count - количество банок после покупки.

2) Запрашиваем сумму денег Васи.

3) Проверяем количество денег, если у Васи денег меньше чем цена одной газировки, то говорим пользователю, что Вася не может купить газировку.

4) Через цикл получаем количество банок и выводим ответ.

Новые вопросы