Информатика, вопрос задал Дмитрий97455 , 10 лет назад

Написать программу приведения дробей к наименьшему общему знаменателю. Пользователь вводит две дроби. Программа приводит дроби к наименьшему общему знаменателю. СРОЧНО

Ответы на вопрос

Ответил Аноним
0
Нахождение НОК двух чисел, оформите под вашу задачу
var
 x, y: integer;
function NOD(x, y: integer): integer;
begin
if x<>0 then NOD:=NOD(y mod x, x)
else NOD:=y;
end;
function NOK(x, y: integer): integer;
begin
NOK:=(x div NOD(x,y))*y;
end;
begin
read(x, y);
write(NOK(x, y));
end.
Новые вопросы