Информатика, вопрос задал allochkayushkevich71 , 7 лет назад

Написать программу при помощи операций div и mod.
1. Задано двузначное число. Найдите среднее арифметическое цифр числа.

Ответы на вопрос

Ответил hello93
0

var  

 a: integer;

 b,c,s: real;

begin

 writeln('Введите число');

 read(a);

 b:=a div 10;

 c:=a mod 10;

 s:=(b+c)/2;

 writeln('Среднее арифметическое: ',s);

end.  

Ответил MrFasty5
0

var a,b,c:integer;

   s:real;

begin

writeln('Введите двузначное число:');

read(a);

b:=a mod 10;

c:=a div 10;

s:=(b+c)/2;

writeln('Среднее арифметическое: ',s);

end.    

Новые вопросы