Написать программу,позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива.Длина массива N задается пользователем как константное выражение.Исходные данные задать вручную или с помощью генератора случайных чисел,учитывая формат элементов массива А.Тип результата определяется из контекста.
-Вычислить количество отрицательных элементов массива;
-сумму модулей элементов массива,расположенных после максимального элемента
Ответы на вопрос
Ответил Mango123
0
const n=
var a:array [1..n] of integer; (целый)
i,k, i_max: byte; max, sum:integer;
begin
randomize; или for i:=1 to n do
for i:=1 to n do readln(a[i]);
a[i]:=random (100);
k:=0
for i:=1 to n do
if a[i]<0 then k:=k+1];
max:=0; i_max:=0;
for i:=1 to n do
if a[i]>max then begin max:=a[i]; i_max:=i; end;
sum:=0;
for i:=i_max to n do
sum:=sum+a[i];
writeln('Количество отрицательных элементов ',k);
writeln('Сумма элементов ', sum);
readln;
end.
var a:array [1..n] of integer; (целый)
i,k, i_max: byte; max, sum:integer;
begin
randomize; или for i:=1 to n do
for i:=1 to n do readln(a[i]);
a[i]:=random (100);
k:=0
for i:=1 to n do
if a[i]<0 then k:=k+1];
max:=0; i_max:=0;
for i:=1 to n do
if a[i]>max then begin max:=a[i]; i_max:=i; end;
sum:=0;
for i:=i_max to n do
sum:=sum+a[i];
writeln('Количество отрицательных элементов ',k);
writeln('Сумма элементов ', sum);
readln;
end.
Ответил Harwey
0
Borland сумеет это прочитать?
Ответил Mango123
0
Это Паскаль.
Ответил Harwey
0
Если не трудно на Борланд сделать?буду благодарен
Новые вопросы
Информатика,
2 года назад
Алгебра,
2 года назад
Литература,
9 лет назад
Математика,
9 лет назад
Математика,
10 лет назад