Информатика, вопрос задал MrSMORC , 8 лет назад

Написать программу:
Попугай Рома вытягивает каждый из семи дней случайным образом число от 1 до 10. Сколько чётных и сколько нечётных чисел он вытянул за неделю.

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(7,1,10); a.Println;
  var kOdd:=a.Where(t->t.IsOdd).Count;
  Writeln(kOdd,' нечетных, ',7-kOdd,' четных')
end.

Пример
7 2 3 4 2 5 3
4 нечетных, 3 четных
Новые вопросы