Информатика, вопрос задал Владиславвввв , 10 лет назад

НАПИСАТЬ ПРОГРАММУ!ПОМОГИТЕ!!!
while и repeat
1)напечатать все отрицательные числа из диапазона от а до б, с шагом h.
2)Напишите программу, при выполнении которой с клавиатуры считывается натуральное число N, не превосходящее 10^9, и выводится сумма четных цифр этого числа и 0, если таких цифр в числе нет

Ответы на вопрос

Ответил ff923
0
1.program z;
var a,b,c:integer;
begin
read(a,b,c);
while (a<b) and (a<0) do
begin
write(a:4);
a:=a+c;
end;
end.
2.program z;
var a,b,c:integer;
begin
read(a,b,c);
repeat
write(a:4);
a:=a+c;
until (a>b) or (a>-1);
end.



Ответил Владиславвввв
0
Напишите программу, при выполнении которой с клавиатуры считывается натуральное число N, не превосходящее 10^9, и выводится сумма четных цифр этого числа и 0, если таких цифр в числе нет
Новые вопросы