Информатика, вопрос задал Alatoria , 9 лет назад

 написать программу ...Пользователь вводит две стороны прямоугольника (целые числа). Определить радиус окружности (с точностью до четырех знаков после запятой), описать около него и его периметр. Сколько окружностей можно нанизать на нитку, с длинной, ровной периметру прямоугольника.

Ответы на вопрос

Ответил AlexKZN
0
Из условий я не понял про нанизывание на нитку окружностей. Остальное сделал на языке Паскаль. На своём компьютере не проверял, т.к. данный язык у меня не установлен. На фото я укзал рисунок моего понимания условий задачи.
- - - - - - - - - - - - -- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
var
     a,b : integer; {описываем длины сторон}
     r,p : real; {описываем радиус и периметр}
begin
   write ('Введите длину первой стороны прямоугольника: ');
   readln(a);
   write ('Введите длину второй стороны прямоугольника: ');
   readln(b);
   r:=(sqrt(a*a+b*b))/2; {находим радиус}
   r:=trunc(r*10000)/10000; {округляем до четырёх знаков после запятой}
   p:=(a+b)*2; {находим периметр прямоугольника};
   writeln('Радиус окружности равен: ',r);
   writeln('Периметр прямоугольника равен: ',p);
end.
Приложения:
Ответил AlexKZN
0
Как вариант, по нанизыванию окружности на нить длинною равной длине периметра:
Ответил AlexKZN
0
p:=Int(p/(2*r)); writeln('Количество окружностей, которое можно нанизывать на нить: ',p);
Ответил AlexKZN
0
Данные две строки, вычисляющие сколько окружностей можно нанизывать на нить, добавить перед командой end (выше команды end)
Новые вопросы