Информатика, вопрос задал Lfox161299 , 2 года назад

Написать программу полностью. СРОЧНО (Паскаль)
"Найти индексы тех элементов массива, у которых значение больше, чем значение предыдущего элемента"

Ответы на вопрос

Ответил ProgrammerV1
1
uses crt;
var a:array [1..100] of integer;
k,n,i:integer;
begin
clrscr;
write('Введите количество элементов массива=');
readln(n);
randomize;
for i:=1 to n do
a[i]:=random(45)-20;
writeln('Исходный массив');
for i:=1 to n do
 write(a[i]:6);
writeln;
for i:=1 to n-1 do
 if a[i+1]>a[i] then 
  writeln('Индексы: ',i:3);
writeln;
readln;
end.

Lfox161299: это точно правильно?
ProgrammerV1: Ну если Вы вообще не понимаете суть задания и алгоритма, который я Вам скинул, то попробуйте разобраться с каждой строкой сами. Учите языки программирования - это интересно
Новые вопросы