Информатика, вопрос задал sultanovzanat37 , 1 год назад

Написать программу поиска двузначных чисел, обладающих следующим свойством: если к сумме цифр числа прибавить квадрат этой суммы, то получится снова данное число. с++

Ответы на вопрос

Ответил Fchchchv
3

Ответ:

Объяснение:

#include <iostream>

using namespace std;

int main() {

for (int i = 10; i <= 99; i++) {

int sum = 0, temp = i;

while (temp > 0) {

sum += temp % 10;

temp /= 10;

}

if (i == sum + sum * sum) {

cout << i << endl;

}

}

return 0;

}

Новые вопросы