Написать программу, подсчитывающую сумму нечетных положительных элементов в одномерном массиве
Ответы на вопрос
Ответил Pro100Cool
0
const
n = 10;var
a :array [1..n] of integer;
i, sum :integer;
begin
for i:= 1 to n do
readln(a[i]);
sum:=0;
for i:= 1 to n do
if (a[i] mod 2 = 1) and (a[i] > 0) then sum:= sum+a[i];
writeln(sum);
end.
n = 10;var
a :array [1..n] of integer;
i, sum :integer;
begin
for i:= 1 to n do
readln(a[i]);
sum:=0;
for i:= 1 to n do
if (a[i] mod 2 = 1) and (a[i] > 0) then sum:= sum+a[i];
writeln(sum);
end.
Новые вопросы