Информатика, вопрос задал duckmol , 8 лет назад

написать программу, подсчитывающую среднее геометрическое всех элементов массива [1..5]

Ответы на вопрос

Ответил Аноним
0
Const
   N = 5;
Var
   A:array[1..N] of integer;
   i:integer;
   P:real;
Begin
Randomize;
P:=1;
Write('Исходный массив:');
For i:= 1 to N do
    Begin
    A[i]:=random(N*2+1);
    Write(' ',A[i]);
    P:=P*A[i];
    End;
WriteLn;
WriteLn('Среднее геометрическое его элементов: ',Power(P,1/N):0:3);
End.
Новые вопросы