Информатика, вопрос задал asdqwerwtwet , 8 лет назад

написать программу подсчитивающую количество цифр целого неотрицательного числа

Ответы на вопрос

Ответил petyaGavrikov
0
var a,k:integer;
begin
write('a (>0) = ');
readln(a);
k:=0;
while a>0 do
 begin
 k:=k+1;
 a:=a div 10;
 end;
writeln('k = ',k);
end.

Пример:
a (>0) = 180653
k = 6
Новые вопросы