Информатика, вопрос задал hatuhov777 , 2 года назад

Написать программу

Подсчитать сумму и произведение членов заданной последовательности. Считывание производится до тех пор, пока не будет введен 0.


ppgem374: Язык?
hatuhov777: С/с++

Ответы на вопрос

Ответил ppgem374
1

#include <iostream>

using namespace std;

int main()

{

   int a, sum = 0, mult = 1;

   cin >> a;

   while (a != 0)

   {

       sum += a;

       mult *= a;

       cin >> a;

   }

   cout << sum << " " << mult;

   return 0;

}

Новые вопросы