Написать программу подсчета цифр заданного n-значного числа. Указать, какие из этих цифр являются простыми. В ПАСКАЛЕ!!!
Ответы на вопрос
Ответил fedrfedr
0
var
n, i: Integer;
s: string;
begin
Write ('Введите число: ');
Read (n);
WriteLn;
s := IntToStr (n);
WriteLn ('Число содержит ', Length (s), ' цифр.');
for i := 1 to Length (s) do begin
if StrToInt (s [i]) in [2, 3, 5, 7] then
WriteLn (s [i], ' - простое число');
end;
end.
Новые вопросы