Написать программу по задаче:
Сформировать массив из 12 элементов случайными числами от 0 до 30. Заполнить массив с клавиатуры и вывести на экран значения элементов массива в строчку.
Ответы на вопрос
Ответил SergeySerg2002
0
Ответ:
Если введенный с клавиатуры режим будет равен "1", то массив нужно будет заполнить вручную, если режим будет равен любому другому положительному числу, то массив заполнится случайными числами и выведется на экран.
Объяснение:
#include <iostream>
#include <ctime>
int main()
{
using namespace std;
setlocale(LC_ALL, "ru");
srand(time(0));
uint16_t arr[12];
int regim;
cout << "Введите режим: " << endl;
cin >> regim;
if (regim == 1)
{
for (uint16_t i = 0; i < 12; i++)
cin >> arr[i];
for (uint16_t i = 0; i < 12; i++)
cout << arr[i] << '\t';
}
else
{
for (uint16_t i = 0; i < 12; i++)
{
arr[i] = rand() % 30;
cout << arr[i] << '\t';
}
}
return 0;
}
Новые вопросы