Информатика, вопрос задал bolotnov991 , 8 лет назад

Написать программу печати чисел Фибоначчи от 1 до 1000, являющихся простыми числами, а также их порядковых номеров в ряду Фибоначчи.

Помогите с программой на паскале .

Ответы на вопрос

Ответил petyaGavrikov
0
var f1,f2,s:longint; k:integer;
function prost(n:longint):boolean;
var j,m:integer;
begin
m:=0;
for j:=2 to trunc(sqrt(n)) do
 if n mod j = 0 then inc(m);
prost:=m=0;
end;
begin
f1:=1; f2:=1;
writeln('№ - Число');
writeln('1 - ',f1);
s:=1; k:=2;
while s<=1000 do
 begin
 if prost(s) then writeln(k,' - ',s);
 inc(k);
 s:=f1+f2;
 f1:=f2;
 f2:=s;
 end;
end.

Результат:
№ - Число
1 - 1
2 - 1
3 - 2
4 - 3
5 - 5
7 - 13
11 - 89
13 - 233
Новые вопросы