Информатика, вопрос задал as190207 , 7 лет назад

Написать программу Паскаль дано целое положительное число напечатать количество и сумму его цифр.Пожалуйста​

Ответы на вопрос

Ответил HappyCoder
0

var

 n, i, count, sum: integer;

begin

 Writeln('Ввидете число: ');

 Read(n);

 count := 0;

 while n <> 0 do

 begin

   i := n mod 10;

   sum += i;

   count += 1;

   n := n div 10;

 end;

 Writeln('Сумма всех цифр: ', sum);

 Writeln('Количество цифр: ', count);

end.

Тестовое решение

Введите число:  

51231

Сумма всех цифр: 12

Количество цифр: 5

Новые вопросы