написать программу Pascal, которая выводила бы число в обратной последовательности
Ответы на вопрос
Ответил geronimo_387
0
procedure Chisla(n : Integer);
var a : Integer;
begin
if (n < 1) then
WriteLn
else
begin
Read(a);
if (Abs(a) < 1000) then
begin
Chisla(n-1);
Write(a,' ');
end
else
Chisla(n);
end;end; function ReadN() : Integer;
var
n : Integer;begin
Write('n=');
ReadLn(n);
if Not(n in [0..1000]) then
n := ReadN();
ReadN := n;end; var
n : Integer; begin
n := ReadN();
WriteLn('Введите ', n, ' целых чисел через пробел и нажмите Enter');
Chisla(n);
end.
var a : Integer;
begin
if (n < 1) then
WriteLn
else
begin
Read(a);
if (Abs(a) < 1000) then
begin
Chisla(n-1);
Write(a,' ');
end
else
Chisla(n);
end;end; function ReadN() : Integer;
var
n : Integer;begin
Write('n=');
ReadLn(n);
if Not(n in [0..1000]) then
n := ReadN();
ReadN := n;end; var
n : Integer; begin
n := ReadN();
WriteLn('Введите ', n, ' целых чисел через пробел и нажмите Enter');
Chisla(n);
end.
Новые вопросы
Математика,
2 года назад
Математика,
2 года назад
Экономика,
8 лет назад
Экономика,
8 лет назад
Литература,
9 лет назад
Биология,
9 лет назад