Информатика, вопрос задал m1mimi , 1 год назад

Написать программу(pascal) для решения задачи,
Вводится последовательность чисел, кратных 3. Найти номера двух соседних чисел из данного набора, произведение которых является минимальным.

Ответы на вопрос

Ответил Puz1koO
1

var

 a,n,min:integer;

begin

 readln(a);

 n:=1;

 min:=100;

 if (a mod 3 <>0) or (a=0) then  

   begin

     writeln('Net par');

     exit;

   end

   else

 begin

   n:=a;

 repeat

   readln(a);

   if a mod 3 <> 0 then break;

   n:=n*a;

   if (n<min) then min:=n;

   n:=a;

 until (a mod 3 <> 0) or (a=0);

 end;

 writeln;

 if min = 100 then writeln('Net par') else

 writeln(Min);

end.

Новые вопросы